Go Back   Forum > Streaming > Forum Generale Streaming

LOGIN / ENTRA

Register FAQ Live Now! Rules Live TV Arcade Search Today's Posts Mark Forums Read



Our website is made possible by displaying online advertisements to our visitors.
Please consider supporting us adding to your whitelist www.coolstreaming.us . Read Guide


Reply
 
Thread Tools Search this Thread Display Modes Translate
  #1  
Old 03-13-2011, 07:59 PM
jobv jobv is offline
Junior Member
 

Join Date: Mar 2011
Posts: 29
jobv is on a distinguished road
Default VLC streaming con webcam

Salve a tutti!

Avrei l'esigenza di realizzare lo streaming da una sala dov'è posto un pc con una webcam (un portatile con webcam integrata) ad un'altra sala dove ci sarà un secondo portatile connesso ad un proiettore.

Ho pensato di utilizzare il mio modem-router wifi e ho cercato, trovato e seguito varie guide per realizzare ciò con VLC ma non riesco ad ottenere nessun rusultato.

I problemi li incontro praticamente da subito:

1) Dal menù Media seleziono Trasmissione (uso la versione 1.1.7 di VLC)

2) Seleziono la scheda Dispositivo di acquisizione con:
a) Modalità di acquisizione: DirectShow
b) Nome del dispositivo: Integrated WebCam

3) Poi vado su flusso e, dopo la sezione Sorgente (in cui non modifico nulla), nella sezione Destinazioni:
a) Spunto Riproduci localmente
b) Nuva destinazione: MS-WMPS (MMSH)
bb) Clicco su aggiungi e imposto l'idirizzo del pc e la porta
c) Profilo: Video -H.264 + ACC (MP4)

Dopo ciò clicco su Flusso e si avvia la trasmissione ma già sul pc che trasmette le cose non vanno: vedo solo una prima immagine (di me che sono avanti alla webcam) e poi non si muove più nulla...

Ho provato anche a creare un mio Profilo (in base a quel poco che ho capito dalle varie guide):
a) Incapsulazione: ASW/WMV
b) Codifica video: H264 con Bitrate:500, Velocità forogrammi: 24, Ridimensiona: 0.65.

Ma sempre lo stesso problema.

Se con VLC apro solo la WebCam (Media->Apri periferica di acquisizione) funziona tutto bene! E lo streming funziona bene (con il profilo personalizzato) anche se tento di trasmettere un filmato gia bello e pronto!

Qualcuno mi potrebbe aiutare!


ToolBar Coolstreaming Reply With Quote
  #2  
Old 03-14-2011, 08:56 AM
jobv jobv is offline
Junior Member
 

Join Date: Mar 2011
Posts: 29
jobv is on a distinguished road
Default

Sono riuscito ad ottenere qualche risultato non utilizzando la webcam integrata ma una normale webcam usb e deselezionando l'opzione Attiva transodifica nella sezione Destinazioni.

Il problema è che la qualità di questa cam è veramente inferiore rispetto a quella della cam integrata quindi vorrei comunque riuscire ad utilizzare quest'ultima.

Ho provato a non usare la transcodifica anche con la webcam integrata e, in questo modo, sul pc che trasmette non ottengo più di vedere il primo "frame" e che poi tutto si blocca, ma tutto fila liscio (si vede bene)...

...il problema è nel pc che riceve, o meglio, che non riceve

VLC non mi da nessun errore di collegamento ma comunque non si vede nulla...
nella Scaletta mi compare l'indirizzo del pc che trasmette ma non accade nulla, non si avvia nessuna riproduzione ne altro.

Qualche consiglio?


ToolBar Coolstreaming Reply With Quote
  #3  
Old 03-14-2011, 09:09 AM
jwllives jwllives is offline
Amministratore
 
jwllives's Avatar
 

Join Date: Apr 2005
Posts: 5,143
jwllives is on a distinguished road
Send a message via MSN to jwllives
Default

non si vede nulla ma lo stream parte (parte il conteggio del tempo) sul ricevente?
__________________
Il regolamento è importante, cercate di leggerlo e di rispettarlo.

LIVE EVENTS HERE!-LOOKING FOR A CHANNEL?-NEWBIE? READ THIS-RULES FOR OT

Grazie a tutti. Jwllives
In vino veritas...in fumo fantasia.


ToolBar Coolstreaming Reply With Quote
  #4  
Old 03-14-2011, 09:50 AM
jobv jobv is offline
Junior Member
 

Join Date: Mar 2011
Posts: 29
jobv is on a distinguished road
Default

Grazie per l'interessamento!

Allora, mi correggo, con webcam inegrata:

1) senza transcodifica sul pc che trasmette si vede e sente bene ma sul pc che riceve non si vede nulla e non parte nulla (incluso il conteggio del tempo)

2) con transcodifica: Video -H.264 + ACC (MP4) sul pc che trasmette si vede solo il primo frame poi si blocca l'immagine e l'audio va a singhiozzo, sul pc che riceve (anche se dopo un pò) si vede e si sente tutto.

Ancora grazie!

Last edited by jobv : 03-14-2011 at 09:52 AM.


ToolBar Coolstreaming Reply With Quote
  #5  
Old 03-14-2011, 03:54 PM
jwllives jwllives is offline
Amministratore
 
jwllives's Avatar
 

Join Date: Apr 2005
Posts: 5,143
jwllives is on a distinguished road
Send a message via MSN to jwllives
Default

dunque tutto risolto...se usassi mp3 come codifica audio?
__________________
Il regolamento è importante, cercate di leggerlo e di rispettarlo.

LIVE EVENTS HERE!-LOOKING FOR A CHANNEL?-NEWBIE? READ THIS-RULES FOR OT

Grazie a tutti. Jwllives
In vino veritas...in fumo fantasia.


ToolBar Coolstreaming Reply With Quote
  #6  
Old 03-15-2011, 04:11 PM
jobv jobv is offline
Junior Member
 

Join Date: Mar 2011
Posts: 29
jobv is on a distinguished road
Default

Ho fatto dei test un pò più seri sul posto, ecco i risultati (ho deciso di utilizzare la webcam integrata perchè, tra quelle che ho, ha la qualità migliore):

Utilizzando il profilo di transcodifica: Video -H.264 + ACC (MP4) sul pc che trasmette (come dicevo) non si vede e sente bene ma ciò non è un problema.

Ho notato però che alcune volte capita che, sul ricevente, si blocca l'immagine per un pò e poi, quando riprende ad andare, è come dire...accellerato...per poi bloccarsi nuovamente. Sembra capitare "casualmente"...e questo mi ha fatto preoccupare un pò...

Ho provato allora con il profilo: Video -VP80 + Vorbis (Webm) e la qualità rispetto al precedente sembra essere leggermente minore ma va comunque bene. Solo che l'audio non andava. Allora ho modificato il profilo utilizzando mp3 (grazie jwllives!) come codec audio e ho risolto.

Il protocollo che ho usato è sempre mmsh.

Visto che io ne capisco poco e niente, potete consigliarmi qualche settaggio migliore che secondo voi dovrei adottare?

Una cosa che invece vorrei risolvere è questa: io mi aspettavo che chi riceve ricevesse con un pò di ritardo ma, così come ho impostato io le cose, questo ritardo è nell'ordine della decina di secondi...forse VLC bufferizza i dati e ciò comporta questo ritardo? C'è modo per diminuirlo?

Grazie a tutti!


ToolBar Coolstreaming Reply With Quote
  #7  
Old 03-15-2011, 06:04 PM
jwllives jwllives is offline
Amministratore
 
jwllives's Avatar
 

Join Date: Apr 2005
Posts: 5,143
jwllives is on a distinguished road
Send a message via MSN to jwllives
Default

una decina di secondi per il ritardo non è male. Per le impostazioni io ho sempre usato HTTP,h.264+mp3. non dà mai problemi ed è di buona qualità.
__________________
Il regolamento è importante, cercate di leggerlo e di rispettarlo.

LIVE EVENTS HERE!-LOOKING FOR A CHANNEL?-NEWBIE? READ THIS-RULES FOR OT

Grazie a tutti. Jwllives
In vino veritas...in fumo fantasia.


ToolBar Coolstreaming Reply With Quote
  #8  
Old 03-15-2011, 06:41 PM
jobv jobv is offline
Junior Member
 

Join Date: Mar 2011
Posts: 29
jobv is on a distinguished road
Default

Ho provato a seguire i tuoi consigli jwllives ma se:

1) nella sezione Destinazioni seleziono il protocollo e clicco su Aggiungi
2) come porta lascio 8080
3) come percorso cancello lo '/' che c'è e metto l'IP del pc che trasmette
4) clicco su Flusso

Non mi si accende neanche la webcam (ed il ricevente dice di non riuscire ad aprire il MRL )

Ps. per la storia del ritardo...non c'è un modo per ridurlo?

Grazie ancora!


ToolBar Coolstreaming Reply With Quote
  #9  
Old 03-15-2011, 07:27 PM
jobv jobv is offline
Junior Member
 

Join Date: Mar 2011
Posts: 29
jobv is on a distinguished road
Default

se al punto 3 invece non cancello nulla e metto il nome del pc (che ottengo con echo %COMPUTERNAME% in un finestra "DOS") la webcam si accende...

...ma, se nel ricevente gli dico di aprire il flusso in http://nomecomuter: porta/ mi dice di non riuscire ad aprire il MRL.

Dov'è che sbaglio?


ToolBar Coolstreaming Reply With Quote
  #10  
Old 03-16-2011, 10:26 AM
jwllives jwllives is offline
Amministratore
 
jwllives's Avatar
 

Join Date: Apr 2005
Posts: 5,143
jwllives is on a distinguished road
Send a message via MSN to jwllives
Default

la porta 8080 suppongo tu l'abbia aperta sul router. per quel che riguardo l'indirizzo...io lo lascio vuoto. trasmette sia in locale che in rete. se vai poi a mettere http://tuoip:8080 oppure mms://tuoip:8080 sul pc ricevente dovrebbe andare. Il fatto che non legga la webcam può dipendere da molte cose...fai occhio che la webcam non sia già in uso da qualche parte...
__________________
Il regolamento è importante, cercate di leggerlo e di rispettarlo.

LIVE EVENTS HERE!-LOOKING FOR A CHANNEL?-NEWBIE? READ THIS-RULES FOR OT

Grazie a tutti. Jwllives
In vino veritas...in fumo fantasia.


ToolBar Coolstreaming Reply With Quote
Reply







Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT +2. The time now is 12:15 AM.



Powered by: vBulletin Version 3.0.7
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.1.0 ©2007, Crawlability, Inc.