Go Back   Forum > Tecno-Cool > Hardware & Software

LOGIN / ENTRA

Register FAQ Live Now! Rules Live TV Arcade Search Today's Posts Mark Forums Read






Reply
 
Thread Tools Search this Thread Display Modes Translate
  #1  
Old 01-31-2008, 05:54 PM
ABNormal ABNormal is offline
Administrator
 
ABNormal's Avatar
 

Join Date: May 2005
Posts: 3,995
ABNormal is on a distinguished road
Send a message via ICQ to ABNormal Send a message via MSN to ABNormal Send a message via Yahoo to ABNormal
Default

problemi con un XML


ho un problema:

premesso che il risultato deve essere un
PHP Code:
 http://www.uusee.com/player/newplayer/uu_play.php?id={E8C30A79-00E0-88D7-BF2C-68C65E39D259}&name=stooge&type=102&info=1&platform=uu_shell 

in un xml ho questo dato:
PHP Code:
 <TV>CCTV SOCCER</TV>
<
URL>{AA062A0B-3F2F-0777-5D62-1144DDD603B8}&name=STOOGE&type=109&info=1&platform=uu_shell</URL

ma la sua lettura, tramite un XSL con la seguente istruzione:
PHP Code:
 <xsl:attribute name="href">http://www.uusee.com/player/newplayer/uu_play.php?id=<xsl:value-of select="URL"/></xsl:attribute> 

mi da errore sull'uguale (&name=STOOGE) e immagino che daranno, in serie, errore tutto i parametri aggiuntivi.
come ovviare?
forse con una serie di accrescimenti successivi del valore del href nel xsl?

come sempre AIUTO OGHER, per favore!!

PS: per completare dico che ho provato a mettere come url solo la prima parte (quella tra partentesi graffe) portando tutti gli altri dati nel xsl ma il risultato (errore) è uguale
__________________
«Fino a quando il colore della pelle sarà più importante del colore degli occhi ci sarà sempre la guerra.» Bob Marley

Last edited by ABNormal : 01-31-2008 at 06:31 PM.


Reply With Quote
  #2  
Old 01-31-2008, 06:50 PM
Ogher Ogher is offline
Amministratore offroad
 
Ogher's Avatar
 

Join Date: Jul 2005
Location: Foam pit
Posts: 1,879
Ogher is on a distinguished road
Send a message via MSN to Ogher
Default

puoi mandarmi in privato i file completi? non mi ricordo più niente di sta roba se mi fai vedere quello che hai fatto magari riesco a trovare il problema
__________________
"Ad Ancelotti glielo dico sempre: 'Immagina se avessi i piedi buoni, non sapremmo dove mettere le coppe...'." G.Gattuso
"Chi vince a Siena ritorna a Siena, chi vince ad Atene va a Tokyo.." C.Pellegatti
"Meglio 1-0 per noi che 1-0 per loro.." C.Pellegatti
Io sono contro l'uso di animazioni al posto del testo su MSN
Non mandatemi messaggi privati con richieste d'aiuto su partite/software, alle partite non rispondo e per i software ci sono i sottoforum dedicati.


Reply With Quote
  #3  
Old 01-31-2008, 09:04 PM
Ogher Ogher is offline
Amministratore offroad
 
Ogher's Avatar
 

Join Date: Jul 2005
Location: Foam pit
Posts: 1,879
Ogher is on a distinguished road
Send a message via MSN to Ogher
Default

L'errore era facilmente rilevabile basta aprire l'xml su firefox per capire che c'è un qualche carattere contenuto tra i tag URL che dà fastidio ai parser.
Ho fatto 2/3 prove e il carattere incriminato è &. Per risolvere basta sostituire & con %26 (questo è il formato dei caratteri nelle url, basta usare %XX dove XX è il valore in esadecimale del carattere, basta guardare la tabella ascii http://it.wikipedia.org/wiki/Ascii)

Ecco una stringa corretta:
Code:
{4A45C8F3-0F16-C8CD-513C-E82CCD6097D2}%26name=STOOGE%26type=109%26info=1%26 platform=uu_shell

Ho provato in locale e funziona
__________________
"Ad Ancelotti glielo dico sempre: 'Immagina se avessi i piedi buoni, non sapremmo dove mettere le coppe...'." G.Gattuso
"Chi vince a Siena ritorna a Siena, chi vince ad Atene va a Tokyo.." C.Pellegatti
"Meglio 1-0 per noi che 1-0 per loro.." C.Pellegatti
Io sono contro l'uso di animazioni al posto del testo su MSN
Non mandatemi messaggi privati con richieste d'aiuto su partite/software, alle partite non rispondo e per i software ci sono i sottoforum dedicati.


Reply With Quote
Reply







Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


>

All times are GMT +2. The time now is 12:24 PM.


Powered by: vBulletin Version 3.0.7
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.1.0 ©2007, Crawlability, Inc.